No marketplace entries found to handle maven-compiler-plugin:3.1:compile in Eclipse. - java - 方帮信
分享
当前位置: 首页 >  > 技术 > 软件开发 > java

No marketplace entries found to handle maven-compiler-plugin:3.1:compile in Eclipse.

2019/2/25 20:54:31 浏览

新导入maven项目后,出现如下异常:No marketplace entries found to handle maven-compiler-plugin:3.1:compile in Eclipse. Please see Help for more information.解决方案:从错误信息来看,没有获取到编译的插件,可能是版本不对应导致的问题,所以按照常规做法,导…

新导入maven项目后,出现如下异常:
No marketplace entries found to handle maven-compiler-plugin:3.1:compile in Eclipse.  Please see Help for more information.
解决方案:从错误信息来看,没有获取到编译的插件,可能是版本不对应导致的问题,所以按照常规做法,导入后,直接项目更新maven对应的项目依赖。如下图: 

1.png


往往这种方式不灵


搜索本地的repository下的 maven-complier-plugin的版本,查看和报错的信息是否一致,如果版本你不一致,或者含有lastupdated后缀的文件。直接删除后,再重新更新POM.xml

QQ20200311-144806.png

对应的版本完成更新之后,应该就没有问题了。文内使用的工具是 everything.exe,这个如果能直接找到的话,不用它也没问题。

来源:方帮信(微信:changyandoublog,邮箱:changyandou@126.com),欢迎分享!